Few Advises for "Thrustmaster ForceFeedback Wheels"

Hello
did you update the driver and firmware for your base ?

I had the same problem with my TS-XW wheel base and I solved the problem updating the driver and the firmware.
The procedure below applies to the TS-XW base, but most likely you can find something similar for your base in TM support.

First you want to dowload these two files from the Thrustmaster support page:
Executable file: PC - DRIVERS FORCE FEEDBACK [Package 2024_TTRS_1.exe] + Firmware
PDF instructions: Firmware TS-XW Racer - Update Procedure [System Requirement: Windows® 10 / 11]


Run the exe file. It will remove the old driver on your PC and then it will install the new one (perhaps you have to run the file twice).
As soon as that is done you must update the firmware. Just open the PDF file and follow the instruction.
It is very important you can read firmware version 8.07 (for TS-XW base!) in the wheel ctrl panel windows at the end of this process.

View attachment 998

And now, my force feedback works in LMU. :)
Thank you very much it worked my firmware was not in the right version even after updating the software. So I downloaded the new software and it worked.(y)
 
Hello , I'm having problems with my t300RS steering wheel with the Alcantara wheel. When I turn my wheel 90°, my steering wheel in the game only turns 45°, so there's no in-game adaptation. What should I do?
Normally, it should adapt to the car automatically.

1710278559466.png

1710278572908.png
1710278697973.png

Sorry for french screenshot


I have the impression that when I turn the steering wheel quickly, it goes to 90°, except that something is readjusting it to 45°.

Thank you for your help
 
Hello , I'm having problems with my t300RS steering wheel with the Alcantara wheel. When I turn my wheel 90°, my steering wheel in the game only turns 45°, so there's no in-game adaptation. What should I do?
Normally, it should adapt to the car automatically.

View attachment 1263

View attachment 1264
View attachment 1265

Sorry for french screenshot


I have the impression that when I turn the steering wheel quickly, it goes to 90°, except that something is readjusting it to 45°.

Thank you for your help
Do you have "steering help" aid activated?
 
Hello , I'm having problems with my t300RS steering wheel with the Alcantara wheel. When I turn my wheel 90°, my steering wheel in the game only turns 45°, so there's no in-game adaptation. What should I do?
Normally, it should adapt to the car automatically.

View attachment 1263

View attachment 1264
View attachment 1265

Sorry for french screenshot


I have the impression that when I turn the steering wheel quickly, it goes to 90°, except that something is readjusting it to 45°.

Thank you for your help

Do you have the latest drivers installed ?
If yes, have you tried different combinations of the 2 parameters "Utiliser..." instead of both "Oui" ?
 
Could u work in thrustmaster wheels? This is a serious issue here and rfactor2. U could make something like assetto corsa competizione. I left rfactor for this issue.
 
Buongiorno a tutti ho un Thrustmaster t818t concorona Ferrari F1000 gia aggiornato con tutti i drive ma non riesco a far funzionare lo schermo e i led come posso risolvere ? Con altri similatori funziona tutto
 
If you are on the latest Simhub then open Simhub click Add/remove features and scroll the list until you find the Simhub to F122020 UDP and toggle on show in left main menu.
Thanks for wanting to help me. Still, I am left with a problem with SIMhub. I have followed all the advice but still no connection with SF1000.
Yet SIMhub indicates that it is receiving data but does not forward it. With UDP relay I entered the IP of the steering wheel, but still no data on the steering wheel. I also manually copied the files into Le Mans Ultimate (found this on YouTube) but it still doesn't work.You also indicate that UDP F122020 must be enabled in the menu, but this is not listed. I do find UDP relay to be enabled.


1717853696469.png
 
Last edited:
Thanks for wanting to help me. Still, I am left with a problem with SIMhub. I have followed all the advice but still no connection with SF1000.
Yet SIMhub indicates that it is receiving data but does not forward it. With UDP relay I entered the IP of the steering wheel, but still no data on the steering wheel. I also manually copied the files into Le Mans Ultimate (found this on YouTube) but it still doesn't work.You also indicate that UDP F122020 must be enabled in the menu, but this is not listed. I do find UDP relay to be enabled.


View attachment 2869


The post here has not been updated. But since monday, the SF1000 Wheel screeen & LED is working :p

How to turn on ?

1. Settings
2. Controller
3. Wheel & Pedals
4. Calibrate
5. 'Use Hardware display' and turn on
 
Back
Top